Answers is deprecated.

Please use Forum to participate in community by asking and answering questions!

Hello,

I'm now learning how to develop app in playcanvas. When I modify some script codes in code editor, I can't move current cursor by arrow key button in chrome browser. Except for moving cursor by mouse, are there ways to move cursor by keyboard ? I think it is not convenient for developing app. Please let me know solution.

Thanks,

asked 30 Nov '16, 15:54

ubbox's gravatar image

ubbox
0112
accept rate: 0%

edited 30 Nov '16, 16:21

You should be able to use the arrow keys to navigate through the code editor. Do you get any console errors in your browser? Try opening the console and check it out (Cmd+I on mac or Ctrl +Shift+ I on windows)

(30 Nov '16, 16:30) vaios

Thanks for comment. I checked inspect(console) in chrome browser, and I got below error message whenever I pressed any key in code editor:

code-editor.js:34966 Uncaught TypeError: Cannot read property 'length' of undefined
     shouldComplete @ code-editor.js:34966
     (anonymous function) @ code-editor.js:34975
     CodeMirror.signal @ code-editor.js:12759
     signalDOMEvent @ code-editor.js:12800
     onKeyDown @ code-editor.js:8717
     (anonymous function) @ code-editor.js:7733

I currently use Ubuntu 16.04, and chrome browser version is 'Version 50.0.2661.102 (64-bit)'. When I try to edit code in chrome browser of Window 7, it works well. I think there are some problems in chrome browser of Ubuntu.

Thanks,

link

answered 01 Dec '16, 03:19

ubbox's gravatar image

ubbox
0112
accept rate: 0%

edited 01 Dec '16, 05:16

Interesting - we will have a look at that thank you.

(01 Dec '16, 07:54) vaios

Would it be possible for you to upgrade to the latest version of Chrome on Ubuntu and tell me if this still happens for you? It seems that for some reason the key property of the Keyboard Event is undefined there which sounds like a Chrome bug.

(01 Dec '16, 08:00) vaios

OK, I will try to upgrade. And let you know about the result later. I'm now using firefox in Ubuntu, and there is no problem. Thanks,

(01 Dec '16, 08:25) ubbox

Have you tried running Chrome with all your extensions turned off (if any installed)? Chrome v50 is also a bit old, have you tried an update to date version on Ubuntu?

We do have a local developer on Ubuntu with Chrome and hasn't hit this issue?

link

answered 09 Dec '16, 13:15

stevenyau's gravatar image

stevenyau
1202
accept rate: 33%

I recently tried to update latest chrome, and it works well. This is maybe related with chrome problems. Thanks for answer.

(26 Dec '16, 09:36) ubbox
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×15
×12
×12
×1

Asked: 30 Nov '16, 15:54

Seen: 688 times

Last updated: 26 Dec '16, 09:36

about | privacy | support | contact

playcanvas